Welcome guest, is this your first visit? Click the "Create Account" button now to join.

To disable ads, please log-in.

Shop at TeamEstrogen.com for women's cycling apparel.

Results 1 to 5 of 5
  1. #1
    Join Date
    Oct 2007
    Location
    Indianapolis, IN
    Posts
    1,039

    Road Bike shifters

    To disable ads, please log-in.

    My road bike is a 2007 and my shifters that came on it are the originals. For some odd reason they have been starting to seize on me lately. It's not to the point I can't use them but they are getting hard to push at times and feel like it takes more effort to get the gear started to shift than it did. My cables are newer and I've had mechanics look at it and they never can tell anything is wrong. It makes me wonder if they are just simply starting to wear out? I suppose they probably have around 6-7,000 on it? I've changed computers several times so I am not sure exactly. I have the updated 105 road shifters on my commuter which is newer and I have to say I adore that new design after riding on my old shifters today. The new ones have that flat spot on them and it fits my hand a LOT better. I don't feel my neck muscles getting tensed up as much with the new design. The shifting is so much smoother too.

    So should I think about buying some new shifters for my road bike at this point? I would definitely want Ultegra since most of my other equipment on the bike is Ultegra.

    Thoughts?

  2. #2
    Join Date
    Sep 2007
    Location
    Uncanny Valley
    Posts
    14,645
    What kind of shifters are they?
    Speed comes from what you put behind you. - Judi Ketteler

  3. #3
    Join Date
    Oct 2007
    Location
    Indianapolis, IN
    Posts
    1,039
    They are Shimano ST700 STI, "Flight Deck". Originally were for triples but I converted to a compact.
    Last edited by WindingRoad; 03-18-2012 at 07:03 PM.

  4. #4
    Join Date
    Dec 2010
    Location
    Boise Idaho
    Posts
    1,192
    if you aren't ready to toss them just yet, try soaking them in some solvent. The Bike Hermit just had to do that on a customer's pair as the gunk and grease was causing them to not work at all. Now they are fine.
    Sky King
    ____________________
    Gilles Berthoud "Bernard"
    Surly ECR "Eazi"
    Empowering the Bicycle Traveler
    biketouringnews.com

  5. #5
    Join Date
    Sep 2007
    Location
    Uncanny Valley
    Posts
    14,645
    What I did with my R700s was flush them with solvent (WD-40), which I could do without taking them off the bike - just roll back the hoods, put a catch bottle, drip tray and towels underneath, set your sprayer to "stream," and pump WD into the mechanism and let it stream out.

    But, the symptom I was having - which people here told me the solvent flush was a potential fix - was that the ratchet wouldn't catch, not that it was hard to push. I would push and the lever would move but nothing would happen with the cable. So not the same symptom as yours. Still, couldn't hurt to try.
    Speed comes from what you put behind you. - Judi Ketteler

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •